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Getting Started with Excel 
 

Workbooks and Worksheets:  

A workbook is an Excel file that contains multiple worksheets, storing, 

organizing, and processing data. It acts as a container for all your data, formulas, 

charts, and formatting. 

Rows, Columns, and Cells:  

In Microsoft Excel, a worksheet is organized into a grid structure composed of 

rows, columns, and cells, which form the foundation for entering, storing, and 

manipulating data. Rows run horizontally across the worksheet and are identified by 

numerical values (1, 2, 3, etc.), while columns extend vertically and are labeled 

alphabetically (A, B, C, etc.). The intersection of a row and a column forms a cell, 

which serves as the primary unit for data entry. Each cell has a unique reference based 

on its column and row position, such as A1, B5, or C10. 

Rows in Excel are numbered from 1 to 1,048,576, allowing users to enter large 

amounts of data in a structured format. Similarly, columns are labeled from A to XFD, 

providing a total of 16,384 columns in a single worksheet. This extensive capacity 

enables users to handle complex datasets efficiently. Cells, the fundamental building 

blocks of an Excel sheet, can contain different types of data, including numbers, text, 

dates, and formulas. Users can modify cell properties such as font style, background 

color, and border settings to enhance readability and presentation. Additionally, cells 

can be merged to form larger sections, split for better organization, or formatted to 

display specific data types like currency, percentages, or time. 
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Ribbon and Quick Access Toolbar:  

 

  The Ribbon is a graphical menu at the top of the Excel window that organizes 

commands into tabs and groups. Introduced in Excel 2007, it replaced the traditional drop-

down menus, making tools more accessible and user-friendly. The Ribbon dynamically 

adjusts based on the selected task, ensuring relevant commands are available when 

needed. 

Structure of the Ribbon 

The Ribbon consists of three main components: 

1. Tabs – Broad categories that group similar commands. 

2. Groups – Collections of related commands within each tab. 

3. Commands & Icons – Specific tools and actions within each group. 

 

Main Tabs in the Ribbon 

1. File Tab ("Backstage View") 

o Used for opening, saving, printing, and managing Excel files. 

o Includes options like New, Open, Save, Save As, Print, Share, Export, 

and Options. 

2. Home Tab (Default Tab) 

o Contains frequently used commands such as formatting, font styles, 

alignment, number formatting, sorting, filtering, and clipboard functions 

(Cut, Copy, Paste). 
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3. Insert Tab 

o Used for adding elements such as tables, charts, pivot tables, images, 

shapes, and hyperlinks. 

4. Page Layout Tab 

o Controls the appearance of the worksheet, including page setup, 

margins, themes, print area, and background settings. 

5. Formulas Tab 

o Provides access to Excel’s built-in functions (e.g., SUM, AVERAGE, IF, 

VLOOKUP), formula auditing tools, and calculation settings. 

6. Data Tab 

o Used for importing, organizing, and analyzing data, including sorting, 

filtering, data validation, and What-If Analysis. 

7. Review Tab 

o Contains tools for spell check, comments, track changes, and protecting 

the worksheet/workbook. 

8. View Tab 

o Allows customization of the Excel workspace, including zoom options, 

freeze panes, gridlines, and different view modes (Normal, Page Layout, 

Page Break Preview). 

9. Developer Tab (Optional, must be enabled) 

o Provides access to macros, VBA (Visual Basic for Applications), ActiveX 

controls, and form creation tools for automation. 
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10. Help Tab 

 Offers access to Excel Help, tutorials, training, and support resources. 

Contextual Tabs 

These tabs appear only when working with specific objects, such as charts, tables, 

or pictures. Examples include:  

 Chart Tools (appears when a chart is selected). 

 Table Tools (appears when working with tables). 

 Drawing Tools (appears when working with shapes). 

Customizing the Ribbon 

 Users can add, remove, or rearrange Ribbon tabs and groups through File → 

Options → Customize Ribbon. 

 Third-party add-ins can extend Ribbon functionality with additional features. 

Basic Operations: 

Entering Data in Cells 

 A cell is the intersection of a row and a column where data is entered. 

 Excel supports various data types, including:  

o Text (e.g., "Product Name") 

o Numbers (e.g., 100, 25.5) 

o Dates and Times (e.g., "01/01/2025", "12:30 PM") 

o Formulas  
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Entering Data in Cells 

 Click on a cell and type text, numbers, dates, or formulas. 

 Press Enter to move to the next row or Tab to move to the next column. 

Editing and Deleting Data 

 Edit a cell → Double-click or select the cell and press F2. 

 Clear contents → Press Delete or use Home → Clear Contents. 

 Undo/Redo → Ctrl + Z (Undo) and Ctrl + Y (Redo). 

Navigating in Excel 

 Move to next cell → Tab (Right), Shift + Tab (Left). 

 Move between worksheets → Ctrl + Page Up/Page Down. 

 Go to a specific cell → Ctrl + G or F5, then enter a reference (e.g., A10). 

Basic Formatting in Excel 

Text Formatting 

 Bold (Ctrl + B), Italics (Ctrl + I), Underline (Ctrl + U). 

 Font size and style → Home → Font. 

 Text alignment → Left, Center, Right & Wrap Text to fit long text. 

Number Formatting 

 General → Default format. 

 Currency → Adds currency symbols (e.g., $100.50). 

 Percentage → Converts numbers to percentages (e.g., 0.75 → 75%). 
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 Date & Time → Formats numbers as dates (01/01/2025) or time (12:30 PM). 

Applying Borders and Fill Colors 

 Borders → Highlight cells with outlines (Home → Borders). 

 Fill Color → Change background color (Home → Fill Color). 

 Font Color → Change text color (Home → Font Color). 

Merging and Wrapping Text 

 Merge & Center → Combines multiple cells into one. 

 Wrap Text → Adjusts text to fit within a cell. 

Basic Mathematical Operations in Excel 

Excel supports basic arithmetic calculations: 

 Addition (+) → =A1 + B1 

 Subtraction (-) → =A1 - B1 

 Multiplication (*) → =A1 * B1 

 Division (/) → =A1 / B1 

 Exponentiation (^) → =A1^B1 

Using Basic Formulas 

 SUM → =SUM(A1:A10) adds all values in the range. 

 AVERAGE → =AVERAGE(A1:A10) finds the mean. 

 MAX/MIN → =MAX(A1:A10), =MIN(A1:A10) find the highest and lowest 

values. 

 IF Statement → =IF(A1>50, "Pass", "Fail") (Conditional logic). 
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Cell Referencing in Formulas 

 Relative Reference → Adjusts when copied (=A1+B1 becomes =A2+B2). 

 Absolute Reference ($) → Stays fixed when copied (=$A$1 + $B$1). 

 Mixed Reference ($A1 or A$1) → Fixes either the row or column. 

Sorting and Filtering Data 

Sorting Data 

 Select data and go to Data → Sort. 

 Sort A-Z (Ascending) or Sort Z-A (Descending). 

 Sort based on multiple criteria (e.g., Name, then Date). 

Filtering Data 

 Apply a Filter (Data → Filter) to display only specific values. 

 Example: Show only sales greater than $1000. 

Copying, Pasting, and Autofill 

Basic Copy-Paste Operations 

 Copy (Ctrl + C), Cut (Ctrl + X), Paste (Ctrl + V). 

 Paste Special → Paste only values, formulas, or formatting. 

Using Autofill for Quick Data Entry 

 Drag the fill handle (bottom-right of a cell) to auto-fill numbers, dates, or 

formulas. 

 Example: Type "Jan" in a cell, drag down to auto-fill "Feb", "Mar", etc." 



ROHINI COLLEGE OF ENGINEERING AND TECHNOLOGY 

24MG206-Optimization Techniques 

 

 

 

Basic Data Visualization (Charts and Graphs) 

Inserting Charts 

 Select data → Click Insert → Charts. 

 Choose from Column, Line, Pie, Bar, Scatter, etc. 

Formatting a Chart 

 Modify chart title, axes, legends, and data labels. 

 Change chart type (Chart Tools → Change Chart Type). 

Printing and Page Setup 

Print Options 

 Print Preview (Ctrl + P) → Check before printing. 

 Set Print Area (Page Layout → Print Area). 

 Fit to One Page → Scale sheet to fit within a single page. 

Action Shortcut 

Save Workbook Ctrl + S 

Open Workbook  

 

 
Ctrl + O 

 

Undo  

 

 
Ctrl + Z 

 

Redo  

 

 
Ctrl + Y 

 

Select Entire Column 
 

 

 
Ctrl + Space 
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Select Entire Row 
 

 

 
Shift + Space 

 

Insert New Row 
 

 

 
Ctrl + Shift + "+" 

 

Insert New Column 
 

 

 
Ctrl + Shift + "+" 

 

Delete Selected Row/Column 
 

 

 
Ctrl + "-" 

 

Apply AutoSum 
 

 

 
Alt + = 

 

Hide Row  

 

 Ctrl + 9 

 

Hide Column  

 

 
Ctrl + 0 

 

 

 Functions 

Functions in Excel are predefined formulas that perform calculations, data 

analysis, and logical operations. They simplify complex mathematical operations and 

save time by automating calculations. Functions are used in financial analysis, 

statistical evaluation, data management, and decision-making. 

Functions in Excel always begin with an equal sign (=) followed by the 

function name and arguments enclosed in parentheses. 

Example: =SUM(A1:A10), which adds values in the range A1 to A10. 

Types of Functions in Excel 

Excel provides a wide range of functions grouped into different categories: 

1. Mathematical and Arithmetic Functions 
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2. Statistical Functions 

3. Logical Functions 

4. Text Functions 

5. Date and Time Functions 

6. Lookup and Reference Functions 

7. Financial Functions 

 

2. Mathematical and Arithmetic Functions 

Mathematical functions perform basic and advanced numerical calculations. 

Common Mathematical Functions 

Function Description Example 

SUM Adds values in a range 
=SUM(A1:A5) → Adds values in A1 

to A5 

AVERAGE Returns the average of numbers 
=AVERAGE(A1:A5) → Calculates 

the mean 

ROUND 
Rounds a number to a specified 

decimal place 
=ROUND(12.3456, 2) → 12.35 

INT 
Returns the integer part of a 

number 
=INT(12.75) → 12 
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Function Description Example 

MOD 
Returns the remainder after 

division 
=MOD(10, 3) → 1 

ABS 
Returns the absolute value of a 

number 
=ABS(-15) → 15 

SQRT 
Returns the square root of a 

number 
=SQRT(16) → 4 

POWER Raises a number to a power =POWER(3, 2) → 9 (3²) 

 

3. Statistical Functions 

Statistical functions help analyze and summarize data sets. 

Function Description Example 

COUNT 
Counts the number of numeric values in 

a range 
=COUNT(A1:A10) 

COUNTA Counts the number of non-empty cells =COUNTA(A1:A10) 

COUNTBLANK Counts the number of empty cells =COUNTBLANK(A1:A10) 

MAX Returns the largest number in a range =MAX(A1:A10) 

MIN Returns the smallest number in a range =MIN(A1:A10) 
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Function Description Example 

MEDIAN Returns the median value in a range =MEDIAN(A1:A10) 

MODE 
Returns the most frequently occurring 

value 
=MODE(A1:A10) 

STDEV 
Estimates standard deviation of a 

sample 
=STDEV(A1:A10) 

 

4. Logical Functions 

Logical functions test conditions and return TRUE or FALSE based on the result. 

Function Description Example 

IF Returns a value based on a condition =IF(A1>50, "Pass", "Fail") 

AND Returns TRUE if all conditions are true =AND(A1>50, B1<100) 

OR 
Returns TRUE if at least one condition is 

true 
=OR(A1>50, B1<100) 

NOT Reverses a logical value =NOT(A1>50) 

IFERROR Returns a custom value if an error occurs 
=IFERROR(A1/B1, 

"Error") 
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5. Text Functions 

Text functions manipulate and format text data.  

Function Description Example 

LEFT 
Extracts characters from 

the left 
=LEFT("Excel", 2) → "Ex" 

RIGHT Extracts characters from 

the right 
=RIGHT("Excel", 2) → "el" 

MID 
Extracts a substring from a 

text string 
=MID("Excel", 2, 3) → "xce" 

LEN 
Returns the number of 

characters in a string 
=LEN("Excel") → 5 

TRIM 
Removes extra spaces 

from text 
=TRIM(" Hello ") → "Hello" 

CONCATENATE / 

CONCAT 

Joins text from multiple 

cells 
=CONCAT(A1, B1) 

UPPER Converts text to uppercase =UPPER("hello") → "HELLO" 

LOWER Converts text to lowercase =LOWER("HELLO") → "hello" 

PROPER 
Capitalizes the first letter 

of each word 

=PROPER("excel function") → 

"Excel Function" 

 



ROHINI COLLEGE OF ENGINEERING AND TECHNOLOGY 

24MG206-Optimization Techniques 

 

 

 

6. Date and Time Functions 

Date and time functions perform calculations related to dates and times.  

Function Description Example 

TODAY Returns the current date =TODAY() 

NOW Returns the current date and time =NOW() 

YEAR Extracts the year from a date =YEAR(A1) 

MONTH Extracts the month from a date =MONTH(A1) 

DAY Extracts the day from a date =DAY(A1) 

DATEDIF 
Calculates the difference between two 

dates 

=DATEDIF(A1, B1, "Y") 

(Years) 

EOMONTH Returns the last day of the month =EOMONTH(A1, 0) 

 

7. Lookup and Reference Functions 

These functions search for values in a dataset. 
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Function Description Example 

VLOOKUP 
Searches for a value in a column =VLOOKUP(101, A2:B10, 2, 

FALSE) 

HLOOKUP Searches for a value in a row 
=HLOOKUP(101, A1:G2, 2, 

FALSE) 

INDEX 
Returns the value at a specified 

position 
=INDEX(A1:C3, 2, 3) 

MATCH 
Returns the position of a value in a 

range 
=MATCH(50, A1:A10, 0) 

CHOOSE 
Selects a value from a list based on 

an index 

=CHOOSE(2, "Red", "Blue", 

"Green") 

 

8. Financial Functions 

These functions are useful for financial analysis and calculations. 

Function Description Example 

PMT Calculates loan payment =PMT(5%/12, 60, -5000) 

PV Calculates present value of an investment =PV(5%, 10, -1000, 0, 1) 

FV Calculates future value of an investment =FV(5%, 10, -1000, 0, 1) 

 


	Getting Started with Excel
	Structure of the Ribbon
	Main Tabs in the Ribbon
	Contextual Tabs
	Customizing the Ribbon
	Entering Data in Cells
	Editing and Deleting Data
	Navigating in Excel
	Basic Formatting in Excel
	Text Formatting
	Number Formatting
	Applying Borders and Fill Colors
	Merging and Wrapping Text

	Basic Mathematical Operations in Excel
	Using Basic Formulas
	Cell Referencing in Formulas

	Sorting and Filtering Data
	Sorting Data
	Filtering Data

	Copying, Pasting, and Autofill
	Basic Copy-Paste Operations
	Using Autofill for Quick Data Entry

	Basic Data Visualization (Charts and Graphs)
	Inserting Charts
	Formatting a Chart

	Printing and Page Setup
	Print Options

	Types of Functions in Excel
	2. Mathematical and Arithmetic Functions
	Common Mathematical Functions

	3. Statistical Functions
	4. Logical Functions
	5. Text Functions
	6. Date and Time Functions
	7. Lookup and Reference Functions
	8. Financial Functions


