24EE404 IOT SENSORS AND DEVICES

Wi-Fi Modules for Arduino

Use your Arduino Uno WiFi on the Arduino Desktop IDE
If you want to program your Arduino Uno WiFi while offline you need to install the Arduino

Desktop IDE.
Installing Drivers for the Uno WiFi

OSX The first time you plug an Uno WiFi into a Mac, the "Keyboard Setup Assistant” will
launch. There's nothing to configure with the UNO WiFi, so you can close this window by
clicking the red button in the top left of the window.

Windows (tested on XP, 7, Vista and 10) At this point of this Getting Started guide you
already have installed the drivers together with the Arduino Software (IDE) and the board will
be recognized automatically.

Open your first sketch
Open the LED blink example sketch: File > Examples >01.Basics > Blink.
Select your board type and port

You'll need to select the entry in the Tools > Board menu that corresponds to your Arduino
Uno WiFi board.

Select the serial device of the board from the Tools | Serial Port menu. This is likely to
be COM3 or higher (COM1 and COM2 are usually reserved for hardware serial ports). To

find out, you can disconnect your board and re-open the menu; the entry that disappears should
be the Arduino Uno WiFi board. Reconnect the board and select that serial port.

Upload the program

Now, simply click the "Upload" button in the environment.

e@ Blink | Arduino 1.8.0

File Edit Sketch Tools Help

O BEBE

Rlirnle

Wait a few seconds - you should see the RX and TX LEDs on the board flashing. If the upload
is successful, the message "Done uploading.” will appear in the status bar.
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Blink | Arduino - O ¥
File Edit Sketch Tools Help

Blink
11 Y
12 modified 8 May 2014
13 by Scott Fitzgerald
14 xy
15
18
17 4/ the setup function runs once when you press reset or pPower
18 woid setup() |
19 J4 initialize digital pin 13 a=s an output.
z0 pintods (13, OUTPUT):
21}
123 4/ the loop function runs over and over again forewver
24 wolid loopi) {
25 digitalWrite(l3, HIGH): S/ turn the LED on (HIGH iz the v
268 delayilooo) S/ walt for a second
27 digitalWrite(l3, LOW): S/ turn the LED off by making the
2B delayilooo) S/owait for a second
29} v

Arduing Uno WiFi on COMAT

A few seconds after the upload finishes, you should see the on-board LED start to blink. If it
does, congratulations! You've gotten your Uno WiFi board up-and-running for the USB

programming.

Programming via OTA

This board allows you to upload your sketches over the air (OTA) using the WiFi connection.
To get this method working, you need that your board is already connected to the same WiFi
network to which your PC is connected. Please refer to the First Configuration chapter below

to configure and connect the Arduino Uno WiFi to your WiFi network.

Power the board using the USB cable and a 5V USB power supply or use an external power

supply connected to the power connector.. Now the procedure to program the board via OTA is

ROHINI COLLEGE OF ENGINEERING AND TECHNOLOGY



24EE404 IOT SENSORS AND DEVICES

the same of that shown above but it differs only when you select the port. Here are all the
steps..

Select your board type and port

You'll need to select the entry in the Tools > Board menu that corresponds to your Arduino
Uno WiFi board.

Select the board from Tool>Port>Network ports menu

€2 Blink | Arduine - O *
File Edit Sketch Tools Help
Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload
Serial Monitar Ctrl+Shift+M “
Board ’
1.' ) Port i Serial poits
¥
1€ ] COMIT (Arduino Uno)
Programmer 3
17 /7 the sel
18 void setwy Burn Bootloader . Metwork ports
15 / initialize digital pin 13 as an output. . arduinounowifi at 192.168.60.118 (Arduino Uno WiFi)
20 pinfode (13, OUTPUT) callopengate at 192.162.60.102 (Arduine Yiin)
- ' linino at 192.168.60.112 (Arduine ¥dan)

ff the loop function runs over and over again forever

Ly o

F ka
LR T U |

wold loop () |

digitalWrite (13, HIGH) /¢4 turn the LED on (HIGH is the v
2 delay (1000} ; S/ walt Eor a second
2 digitalWrite (13, LOW); /¢4 turn the LED off by making the
28 delay (1000) ; S/ walt Eor a second
29 1 o

Arduing Uno WiF| on 192,168 80,1128

Note: Be sure that the PC and the board are connected to the same network and that the board

is in STA MODE, for more information see First Configuration below.
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Upload the program

Now, simply click the "Upload" button in the environment.

File Edit Sketch Tools Help

Blinl

Wait a few seconds - you should see the RX and TX LEDs on the board flashing. If the upload
is successful, the message "Done uploading.” will appear in the status bar.

First configuration

Your Arduino Uno WiFi needs a first configuration to join your WiFi network and it allows
you to enter the relevant information creating its own Access Point. Please execute the
following procedure every time you bring Arduino Uno WiFi in a location where the WiFi

network access needs to be reconfigured.

Power the board and wait some time. Search the board in the network list, it has an ESSID like
this: Arduino-Uno-WiFi-xxxxxx. Connect your PC/MAC to the Arduino Uno WiFi AP: Open
a browser and connect at this address: http://192.168.240.1/

This is the screen that it will appear:

WELCOME
% Tha Aechumio LRWCH Wi finrmvang aBow's you b upload on Arduing skdch vaa OTA - Ovar The Air igchnoiogy, You
ARDUINO can usa Arduing IDE for thal. Pladss reder bo e onlne Starer Guide on Anduing. ofg
UMD wWiFi
SUMMARY
OVERVIEW
WIFT COMSOLE
Wil stadus idln
WIFI Wil sddress 0.0
WiFi moce AP5TA
CONMECTIVITY T
fiF | cihpneresd ]
DEBUG LOG
Flash chip 10 (reld (o806

Flash sira AMB 512512
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If you want to modify the hostname of the board then click
on CHANGE from OVERVIEW menu or select the WiFi on the left menu and insert a new
name under HOSTNAME field and after click on CHANGE.

WIFT CONFIGURATION

0,0,

ARDUINOD

UMD WiFi
HOSTHAME WIFI STATUS

OVERVIEW e NahwOk
WIFI COMSOLE e
W Hhiress 0000
WIFI COMMECTION - e
WIFI 11
¥ oy in
To connect & a YWiFi nebwork, plaase salecl ons of
COMNECTIVITY e delecied nebrorie, ssar e passwond, aed bit WIFI MAC S ot T 10 etc?
e o aRon,
DEBUG LG SRR Wi mode AF+STA
Mabwuk SSI0
8 il 5505 DrLabe
O al

Connect the Arduino Uno WiFi to your AccessPoint Router, selecting your network from
the WiFi Menu, insert the correct password and then click on CONNECT, as shown in the

image below:

CB all 51 0
L
B ol 50 nswio
ARDUINO a
il 5308 uramE-wi ADVANCED
LMD wiFi o alll 5208 UnIME WIF
B.I‘| 308 TP-LINK_2t00 Statc 1P
ol 5708 unmee.wi [ owe
OVERVIEW
g all = ME-W
WIFI CONSOLE
a i.l 47 PIME F
g .l I
WIFI 0 il s0am UrimE-
CONNECTIVITY
VWi password
S <= —
COMMECT

When the board is connected to the network, the ip address will appear at the top of the panel:
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—animy Lonnecied God [P 15215860, 110 pmes—

WIFL CONFIGURATION

ARDUINO
UMD wiFi
HOSTHAME WIFI STATUS
(== 41 0] 1
OVERVIEW Canfigund rotwork DHLaks
WIFI COMSOLE WiFs status god 1P acddness
Wik addrgss 162 168 60 110
VitF e ree 5348
WIFI CONNECTION
Wik piry 1in
N0 MU T BT o WiFs MAC Sccf THADed 2

162 168 60,110, else connect bo natwork DHLabs
first Wi mode AP+ETA

To conmcd 108 Wik network, ploas Sebect oni ol

Thas chirlsc isd nitworkes anbesr v passwand and b
has connect Butlon

Now connect the PC to the same network to which the board is connected and try to access the
board by inserting the ip address in the browser.

[ 168,60, 110 home b, o
07 app [T 0% Lot et [ Ardsincceg B Socgle Traralaty Y Bing Tracutiony [ oeTiciortz S0 Corte [l deiiens St [f] driir tacebcckc [ Linowiin [ infoiioe o Morcienis 5 Gmal = 3 Ak Preders

WELCOME

Thea Ariduino LICH WiFs Brvmans aBows you b uphosd an Ardund skedch vaa OTA - Oved This Air tachaolgy. You
ARDUINO can use Arduing I0E for thal. Pleasa reder ko the onlne Stader Guide on Arduing og

MO WiFi

SUMMARY
OVERVIEW
WIFI COMSOLE
Network SSil DHLats [ owe |
fifi SLatrs ol P addneds
WIFI Wil sddnirs 162 168 80,110
COMNECTIVITY Wi mode APSTA
WiFi charnssl 1
DERUG LG
Flash chap ID el (016
Flash sira 4B 512512

Click on WiFi in the left menu and change the Wi-Fi configuration mode switching to STA

MODE, as shown in the image below:
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WIFI CONFIGURATION

OO

ARDUIND

LIMD WiFi
DS THAHE WIFI STATUS

OVERVIEW ailigured restercek 4 ILaks
B g0t P sy

152 108 860110

WIFI CONSOLE

St
WIFI CONNECTION
WIFI 11
Tor conneect 1o Wi network, ploase select ona of
COMMECTIVITY the chebeschesd Metwieks. ender the password, and ha WiiFs WA S i
et Connect buthon )
DEBWG LOG Wi s AP+STA
Notwark $5
e B wil sz v [ v
Ll

Please note: It is important switching in STA MODE because so the board will be visible on
the Arduino IDE and, furthermore, you will be able to protect it from possible attacks, since it

will no longer be visible as open network.

Now the "Mode Changed" message should appear at the top of the panel:

- RMCKPE CIRTE0 -
WIFI CONFIGURATION

0.0,

ARDUIND

LIMNO WiFi
HOSTHAME WIFI STATUS

1
OVERVIEW pnfgared nabwork BHLabs
DTN e p—

192 158600190

WIFI COMSOLE

]
WIFI 1in

T connact ke Wik nebwork, phaase sekect o of
CORNECTIVITY e dedeciad networks, enter the password, and hit Scot T leedc?

ha conmmc] bafion
DEBUG LG ekl moce

Mobwork S5

& il
all s0a8

Now, you can access the webpage using your hostname: http://hostname.local

Your Arduino UNO WiFi is ready.
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Web panel functions details

The Arduino UNO WiFi has a Web panel that it can be reached in different ways:

o If the board hasn't been configured yet, you can access it entering in the browser this
link: http://192.168.240.1/ to configure the board read the First
configuration paragraph.

o If the board is been configured already for your WiFi network then you can insert the ip
address (xxx.xxx.xxx.xxx) or the hostname(hostname.local/) from browser.

The Web panel has a simple menu that it is formed from five items: OVERVIEW, SERIAL
MONITOR, WIFI, CONNECTIVITY and DEBUG LOG.

The Home page of the Web Panel corresponds to OVERVIEW menu, as shown in the image

below:

WELCOME

The Ardianed UMD WAF rrreade allows wou 1o upland an Arding skatich wa OTA . Over The Air schnokogy. You
ARDUINO con wsa Arduing IDE for thal Plaasae rafer b the cnbng Starer Guide on Ardung.oog

UMD WiFi

SERIAL MOMITOR
WOk S5IL DL ke

OVERVIEW

ged 1P nadrass
WEFL 162 V68 G118
COMMECTIVITY WIFi modo STA

DEBUG LG

Oreli Cred 085

AN SRS 12

In the Overviewis shown all the information about the configuration board: thehostname, the
network SSID, Wifi address, Wifi mode and other details
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ARDUINO

LIMEY WiFi

OVERVIEW

SERIAL MOMITOR

arfungunoeath

DHLabs

ol IF addnass

192 168 60 118

ETA

1

O D40 16

4MB 512512

uSer? bin

deialed

criatees dreonnnesthsd

2600

Clicking on SERIAL MONITOR displays a serial monitor, useful to display the

results when you upload a sketch.

©.0;

ARDUIND

LINED wWiFi

OWVERVIEW

SERIAL MOMITOR

SERIAL MONITOR

Furthermore in this section it is possible to reset the microcontroller clicking on RESET pC

button.
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SERIAL MONITOR

ARDUIND

LINEE wiFi

OVERVIEW

SERIAL MINITOR

Text entry

History

RESET pC Rk [

Instead selecting from left menu the WIFI section, you can change the hostname simply typing
the new hostname in the dedicated bar and after to click on CHANGE button, as shown in the

below image:

WIFI COMFIGURATION

©.0)

ARDUIND
LINEY wiFi HOSTMAME WIFL STATUS
1
-_ -
OVERVIEW 2]
gl P adknss
SERIAL MONITOR
WSS 1B 168 60.118
SadbB
WIFI COMNECTION
1in
To connect ta n WiFI nobwork, please solecl ons of Sech TH O:abeaB
tha dedocind natworks, entar thie passwond, and hit
iy conric] buon WiFI moda STA
Mitwork SSIL
SWITCH TD STA+AP HODE
® E .|||| 3B DHLaks

4 | [TV

It is possible also to switch to STA MODE or STA+AP MODE clicking the specific button,
but keep in mind that it is advised to switch only in STA MODE because so the board will be
visible on the Arduino IDE and, furthermore, you will be able to protect it from possible

attacks, since it will no longer be visible as open network.
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©.0)

ARDUINOD

UND Wik

OVERVIEW

SERIAL MONITOR

WIFI COMFIGURATION

HOSTHAME WIFL STATUS

W Choanned

Congurad nabwork

Wi | sialus

W055
551
WIFL COMNECTION
Wi phy
To connact i o WiF1 network. phaase solect on of ML
iy detnciod notworks, aeior the passwond, and hil
thir coanic buion WiFi moda

Mobwork SSI0
o B il 5308 DHLats
T | TR

1

DHLabs

Qi IF pddkess
18E 168 60118
w8

1in
scclTE10eb el

S5TA

It is possible to connect the board to a network selecting it, inserting the correct password and
clicking on CONNECTbutton.

©.0)

ARDUIND

LMY WiFi

OVERVIEW

SERIAL MONITOR

WIFI

COMNECTIVITY

DEBUG LOG

E .|||| 230B Irsing ADVANCED
& il 5008 pisPoLae

i DHI
B il 5148 Ui cxniic IF

@ il 538 UNIME-WIFI
B il 5108 UnmE
0 .l 5548 Arduine. Une WiEL 108325
B il 7ace UninE e
O il 558 Uninee v
B il 5008 UNIvEWE
i atll 55aB UNMEWE

In this section you can also choose if to use the DHCP or the Static IP, as shown in the picture:
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E lII“ 2%B Insing

% & il 5008 pisPoLAD

ARDUINO B il 5108 UninE s e P
UMY wirFi b atll 348 Unive e ﬁ
B il 5108 UnimEwEI

i il 5808 Arduine Uno-WiFi- 10032

SHERIEER B atll 7408 UhimE WE

SERTAL MONITOR E |I“| BEAE LIMINIE I

o ol 5B Unines e

il 5am UnineEws

In the CONNECTIVITY section you can enable the connection services for example the client
MQTT and the SLIP:

CONNECTIVITY

ARDUINO

LIHCE wWiFi
HOTT STATUS REPORTING

Erabia MOTT chond Enaile slalis rpeeiing via MOTT
OVERVIEW MOTT chent state: disconnected
T
SERTAL WOWETOR e areluiny
MBSED0D. ["resi™i-56, “heap free™ 11513
Sarver po
UPDATE
&
WIFL
Chant IL
CONNECTEIVITY ——
SLIP
DEBUG LDG Chant Temacu (Sesconds
REST requests ans anablsd a5 <oom a5 SLIP =
Kpeh Abve ilareal {socoids] anablsd Thare afe no REST.specihe salhngs.
B

Finally in the DEBUG LOG it is shown the debug log and it is possible to reboot the WiFi
clicking the WiFIREBOOT button:
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DEBUG LOG

©,0)

ARDUIND

UNG WiFi

OVERVIEW

SERIAL MONITOR

REFRES5H
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